Moodle Technical Requirements


Hardware
To access Moodle, your computer need only support one or more of the compatible browsers listed below.

Browsers
The following web browsers are supported by Moodle:

  • PC/Windows:
    • Internet Explorer 8 (IE 10 required for drag and drop of files from outside the browser into Moodle) (free download)
    • Firefox 4 or later (free download)
    • Google Chrome 11 or later
    • Opera 9 or later
    • Mac:
      • Firefox 4 or later (free download)
      • Safari 5 or later
      • Google Chrome 11 or later,
      • Opera 9 or later


    Browser Settings


    Viewers/Players/Plug-ins
    To view or access course content, you may need one or more of the following, depending on the type of content posted in the course:

    • Microsoft Word viewer is recommended as faculty members frequently use Word for their course documents (free download)
    • PowerPoint viewer for PowerPoint presentations (free download)
    • Adobe Acrobat Reader for PDF files (free download)
    • Adobe Flash Player for Adobe Flash content (free download)